Release 0.24

Better late than never: Kunagi 0.24 is done! Changes in the new version are twofold.

For Admins, we have an admin view that displays system, service and environment information and log messages. Also, there are functions for backup and safe shutdown.

For other Users, we have some minor UI improvements and several bugfixes. We also worked on our code quality and expect less Exceptions to be thrown that force users to restart the interface.

Lastly, we sat down and made Kunagi work in Internet Explorer 9. As a side effect, it might even work in IE8 now.

Get the new version while it's hot! Here's the complete list of changes:

New Features

  • sto202 Story progress is now visualized in the Whiteboard
  • sto204 Create Story button at the bottom of the PB
  • sto230 Admins have a admin page now, where they can view system information, logs and access a backup and shutdown feature
  • sto220 Users that post Issues to us or subscribe to existing Issues on are now automatically notified about changes
  • sto210 The Personal Preferences page now allows users to sign up for e-mail notification on Kunagi events
  • sto191 Team Velocity at the top of the PB is now displayed graphically as a sparkline chart

Fixed Bugs

  • iss824 FIles that contain a # (and potentially, other "invalid" characters) can now be correctly downloaded from the File Repository
  • iss764 Translated a session logout message that was in German
  • iss769 Cannot open Whiteboard after creating Impediment from Task
  • iss779 Fixed Unexpected Error after switching Sprint
  • iss792 Fixed a bug where an admin user could change his own password without entering his current password
  • iss753 Bade the difference between H1 and H2 in Wiki more distinct
  • iss830 Fixed "null" appearing when Kunagi appends text to an empty Statement
  • iss632 Added missing infos in PDF report for Bugs
  • iss804 Fixed Search throwing an EntityDoesNotExistException
  • iss702 Kunagi should now work with IE9


Mon, Aug 27, 2012, 11:57 by Friedrich

Hey Kunagi Team,

Could it be that you now require another java version to run your webapp?
When trying to upgrade to version 0.24 I get the following exception in my tomcat6 logs:

java.lang.UnsupportedClassVersionError: scrum/server/ScrumServiceImpl : Unsupported major.minor version 51.0 (unable to load class scrum.server.ScrumServiceImpl)

My current java version is
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode, sharing)

I am currently upgrading to java 1.7 but I think a hint on your pages to what java version is required now would be helpful :)

Best regards

Mon, Aug 27, 2012, 11:59 by Friedrich

And by the way, your comment function of this blog seems to be broken.
The html form action is set to "${kunagiUrl}postComment"
But from the bugs page I guessed it should be


Not sure if this is a kunagi bug so I did not post a bugrequest yet.

Tue, Sep 4, 2012, 13:21 by anonymous

hi, I'm very interested in this feature, but I see no where in the personal preference to enable the receive of the email?
The SMTP was well configured and the "test email" was succeed.

Thu, Sep 6, 2012, 21:41 by Witek (SM,T)

W have accidently compiled the latest Kunagi version for Java 7. We have fixed this now. Please download again, if you need Java 6 compatibility. Sorry for the inconvenience.

Post a comment